Foscam integration


Is there any way to view Foscam IP cameras in Roomie?


This is already in current betas for their H.264/RTSP cameras, but not in 2.0.4.

Thank you.


You can view foscams right now by adding an activity with a open url in roomie command.

Most foscams use this format:

ipaddress/videostream.cgi?user=u … d=password

Probably want to create a guest account on your foscam for viewing this way.


Ah yes, we should have clarified that. Like anything that loads in Safari on iOS, you can always just open the URL in Roomie. When we say Foscam is in betas for the next release, it means native Foscam support via RTSP (which is higher quality than the web page interface).

Thank you.


I have a FI8910W, which is shown to be supported for live video feed on port 554. However when I add the camera all I see is a still screen shot, the only way to see anything change in the camera window is to constantly hit refresh. Can someone confirm the steps needed to add the 8910 model into my setup?



It sounds like you’re adding a web URL which is not related to Roomie’s internal support for Foscam. Adding a device to Roomie is via the “Add Device” button, enter your Foscam IP and port 554, and select Video Camera, Foscam. There is no “refresh” button because the video is live.

Thank you.


Yes - I was using the URL to view my feed. However, when I added the camera via “Add Device” I select Foscam and use the RTSP option, enter my username and password. The video feed does not appear, just a black screen. It’s my understanding the FI8910W is an MJPEG camera, not RTSP. Can you confirm?


Yes, the FI8910W is not an RTSP model. We support Foscam’s RTSP models. Any other model would be viewable only to the same extent they’re viewable in Safari for iOS.

Thank you.


For anyone that is having trouble adding a foscam to use teh native functionality in Roomie, here is how I did it. Not sure if this is “best practice” but it worked for me so thought I would share.

First, make sure you have a camera that supports RTSP. The ones on the compatibility list should all work. Originally, Roomie has the 8910 on the list of compatible cameras, so I bought that one, but it does not work. Not surprisingly, that camera is no longer on the list.

Second, you need to know that there are TWO devices you have to add to get this to work. The first is the camera video feed, then second is the controls for up down left right, etc.

So, add each of the two devices via Manual IP…putting in the IP address, and then the proper port number. I changed my port to 8080 per Foscam’s suggestion. I used this new port number for both the RTSP video feed device AND the control device. You will then be asked you choose a device type, choose video camera, then FOSCAM

Make sure when setting up the two devices to choose “RTSP feed” as one device…then when setting up the second choose control.

So, now you should have two devices labeled FOSCAM in the device list, one for RTSP, one for Control.

so, how do you get the two to work together in one activity? this is where I got hung up, until I discovered the “Add Camera” function on the device setup screen.

So, go to the CONTROL device, scroll down until you see add camera, select that and select the RTSP device (the video feed). Now, when you select the control device, it will launch the video feed at the same time.

Of course, you need an activity to do this. So, set up a new activity. There is a logo for FOSCAM you can use, by the way.

In the activity, select OPEN REMOTE FOR…the CONTROL DEVICE, not the RTSP.

You can create a custom remote at the activity level as well, but I won’t go into that here.

When launching this activity, you should see the left right up down contol on top, then a small video feed below. By tapping on the video feed you can enlarge it.

This is how I got it to work, I never used port 554, and honestly am not techie enough to know why I should or should not have used that…but if others can add to this with more suggestions I know we’d all benefit.


I have a foscam r2 and was wondering if this is still the case for setup in v5?