Simple Control on iOS 9.3 (final iOS for iPad-2)


#1

I got a little excited thinking I had found a use for my old iPad-2’s and keep them out of the landfill (I still use them for light duty tasks) … but now I’m not sure.

I’ve read the Introduction (references to the mia Simple Control Legacy) in Simple Control v4.5 User Guide and I see iTunes says “iOS v9.3 or higher”. I currently have SimpleControl-Home v4.5 running on a iPad-Pro and a iPad-2.

I think the best way to ask my question is like this …

  1. On v4.5 to v4.9, how much longer can I use an iPad-2?

  2. Will v5.0 to (let’s say) v5.5, run on iOS 9.3 and an iPad-2?

  3. Will 4.x and 5.x clients be available concurrently?

  4. Can 4.x and 5.x clients be used concurrently, and can the DropBox Backed Config still be shared?


#2

V4.5 runs on iOS 9.3 through iOS 10. We presume it will run on iOS 11 because nobody has reported any issues, but we are currently only testing V5 on that. Certainly, V4.5 is not optimized for iOS 11 per se.

V4.5 will always run on those platforms as it is the last of that line. V5 as we noted previously (see Announcements forum) is a separate app so it wont override whatever device you want to use V4.5 via automatic update, etc.

V5 will require at least 10.3 and at this point likely would require iOS 11. This is a list of iOS 11 compatible devices:

macrumors.com/2017/06/06/io … od-models/

V4.5 and V5 Simple Control environments will be 100% separate. All devices will be either V5 or V4.5. The slight exception to that is, because the appliance Hub gets a forced update, it will work in both a V4.5 and V5 environment. All other software will enforce that members of the mesh are the same version as usual. Nothing else is a forced upgrade. Transitioning to V5 is a separate app for iOS, tvOS, and macOS.

Dropbox is also separate. A new app folder is created on Dropbox by V5. You can rename your old one to transition, or keep both.

While you can also install V4.5 and V5 on the same device at the same time, you should ensure as in the past that Background Refresh is only turned on for the app you actually use. The reason to have them both installed at the same time is for instance if your subscription is tied to the old app and you have not yet transitioned it to the new app or the website.

Thank you.


#3

To clarify if I got this right …

The hardware-appliance Hub that is updated for v5, will continue to work as a Hub for both v4.5 and v5 Simple-Control networks, concurrently?

Using “Simple Hub for iOS” is self-explanatory I suppose. If locked into Guided-Mode, you would have to choose one-or-the-other. Maybe you could have two iOS devices running in house … each as its own version Hub.

AppleTV Gen4/Gen5 … would have to pick because the “Simple Hub for Apple-TV” App has to stay in foreground or in-focus (no multi-tasking on tvOS).

What about “Simple Hub for Mac” ? Can we have both versions running on macOS? It will do it’s job for both kinds of Simple Control networks because we are multi-tasking?


#4

Do not cross the streams. You can remain on 4.5. Or you can upgrade all devices to 5. There is no inbetween. No matter which Hub you use.


#5

Yes, thanks for putting it in “GhostBusters Terms” … now that’s some terminology I can understand. :grinning:

I was just trying to dissect your previous post and discover what is possible. I guess for others as the upgrade questions in various forums are starting.

Personally, I think it would be much easier to do as you say … “You can remain on 4.5. Or you can upgrade all devices to 5”. My head hurts less that way.