AppleTV Beta Program - Don't Upgrade tvOS Beta 11.3


#1

Hi, just a friendly warning to those of us in the Apple Beta program. Do not update to 11.3. There are strange issues with control via remote from dropping connections, to loss of control when in an app, to keyboards not working. There is a note in the update log that says “Restrict Remote app connections to specified iOS devices.”. I’m not sure if this is the root cause but it appears to be affecting the stock Apple iOS TV remote as well. Unpairing/repairing the remote in Simple Control does not help.

This is the first time I have had serious issues on a tvOS beta. I had upgraded hoping for a fix for the washed out colors on the menu in HDR mode but ended up with a bag of hurt, Unfortunately since I have a 4k model (without a USB connection) there isn’t a way for me to downgrade at this time.

Others have commented on similar issues (outside of simple control) https://forums.macrumors.com/threads/apple-tv-11-3-beta-1.2102671/

If anyone has a suggestion I’d love to hear it. Currently running Simple Control 5 in Legacy remote mode.


#2

Very promising! – ignoring minor beta bugs that are to be expected.

I had never heard of “Single App Mode”, but sounds like it started in tvOS 10.2. Apparently it auto-resumes the app even after reboot. This is exactly what I have been hoping for.


#3

Thank you for the heads up @sstarck90213. I just discovered the beta option after the most recent update. @Will_Price, it sounds like single app mode may be more like guided access for ATV. This sounds like good news for SC!!


#4

I wish i had read this thread before updating, but glad to hear it’s not just me. As soon as I updated to beta 11.3, i have no live feedback thru netflix and i lose remote connection as well. Has anyone figured out a fix yet or are we at the mercy of waiting for apple to fix the bugs on their end?

thanks


#5

@jnorris628 So far no fix. I have found one way to consistently knock the ATV ‘offline’ from SC and the Apple remote app is to start a live youtube channel - the only reset is to use the included remote or in some cases pull the power plug. very strange.

I started a ticket with Apple but haven’t had a helpful response. Note if you open a ticket mention that it is the apple remote app that and not SC that loses connection otherwise they will blame SC.

If you have an ATV4 you can use the usb connection and iTunes to roll back to 11.2.5. If you have a ATV 4K without a USB connection there isn’t a way to roll back. Per Apple, turn off beta updates in the menu then wait until the next public update (Which hopefully won’t just be a ‘not fixed’ public release of 11.3 Beta)


#6

10-4. Thanks for the help


#7

Looks like 11.3 Beta 2 was released to developers this morning with a ‘play/pause’ fix for the Apple Remote - no mention of a fix for the network remote. once it hits public beta I’ll update and let you all know what happens.

Space X Falcon Heavy Live on youtube launch also breaks network remote connectivity - so far the regular remote will allow me to stop the video and restore SC.


#8

thanks for the update


#9

tvOS 11.3 beta 2 went public and software update showed it was available this afternoon. (I put the release info below)

So far so good, I believe the issues with network connectivity are resolved for me. I’ve used it for the last hour trying known triggers (like live youtube) to mess it up and it seems stable. Media feedback doesn’t work quite right on Netflix, but it does in other apps. I probably wouldn’t update if you are stable on 11.2.5 but if you are stuck on 11.3 beta 1 I would definitely give it a try.

Note the screenshot. Before I updated to Beta 2 there were no entries under ‘Remote App’ - this must be a log of how many times I had to unpair/pair over the past week.


#10

thanks again sstarck. I was still in the return window so i returned mine last night and bought another one just so i could install the original 11.2.5. All is good now, but i’ll be reading your updates so i’ll know when it’s ready to reinstall the beta.

Good luck


#11

I had the same multitude of entries from my phone with ATV on the standard release version of tvOS. Fortunately, I didn’t opt in for beta thanks to this forum topic!!

I posted about this in another place earlier and @Will_Price said not to bother worrying about the excess of entries, although I worry there’s potentially a maximum number of pairings on a single ATV. Will cross that bridge when i get to it!